W3cubDocs

/Flow

Emacs

flow-for-emacs

You can add support for Flow in Emacs by using flow-for-emacs

Requirements

  • Requires Flow to be installed and available on your path.
  • Requires projects containing JavaScript files to be initialised with flow init.
  • Requires JavaScript files to be marked with /* @flow */ at the top.

Installation

cd ~/.emacs.d/
git clone https://github.com/flowtype/flow-for-emacs.git
echo -e "\n(load-file \"~/.emacs.d/flow-for-emacs/flow.el\")" >> ~/.emacs

© 2013–present Facebook Inc.
Licensed under the BSD License.
https://flow.org/en/docs/editors/emacs