Upgrading Vagrant

If you are upgrading from Vagrant 1.0.x, please read the specific page dedicated to that. This page covers upgrading Vagrant in general during the 1.x series.

Vagrant upgrades during the 1.x release series are straightforward:

  1. Download the new package
  2. Install it over the existing package

The installers will properly overwrite and remove old files. It is recommended that no other Vagrant processes are running during the upgrade process.

Note that Vagrantfile stability for the new Vagrantfile syntax is not promised until 2.0 final. So while Vagrantfiles made for 1.0.x will continue to work, newer Vagrantfiles may have backwards incompatible changes until 2.0 final.

Run into troubles upgrading? Please report an issue if you run into problems upgrading. Upgrades are meant to be a smooth process and we consider it a bug if it was not.

© 2010–2017 Mitchell Hashimoto
Licensed under the MPL 2.0 License.