W3cubDocs

/Yarn

yarn upgrade-interactive

This is similar to npm-check interactive update mode. It provides an easy way to update outdated packages.

yarn upgrade-interactive

The default mode installs and updates the packages to use minor versions.

yarn upgrade-interactive [--tilde/-T]

Using --tilde or -T installs and updates them as patch versions.

yarn upgrade-interactive [--exact/-E]

Using --exact or -E installs and updates them as exact versions.

[1/? Choose which packages to update. (Press <space> to select, <a> to toggle all, <i> to inverse s
election)
 devDependencies
❯◯ autoprefixer      6.7.7  ❯  7.0.0          https://github.com/postcss/autoprefixer#readme
 ◯ webpack           2.4.1  ❯  2.5.1          https://github.com/webpack/webpack

 dependencies
 ◯ bull              2.2.6  ❯  3.0.0-alpha.3  https://github.com/OptimalBits/bull#readme
 ◯ fs-extra          3.0.0  ❯  3.0.1          https://github.com/jprichardson/node-fs-extra
 ◯ socket.io         1.7.3  ❯  1.7.4          https://github.com/socketio/socket.io#readme
 ◯ socket.io-client  1.7.3  ❯  1.7.4          https://github.com/Automattic/socket.io-client#readme

© 2016–2017 Yarn Contributors
Licensed under the BSD License.
https://yarnpkg.com/en/docs/cli/upgrade-interactive