Note
This plugin is part of the community.general collection.
To install it use: ansible-galaxy collection install community.general
.
To use it in a playbook, specify: community.general.aix_lvg
.
Parameter | Choices/Defaults | Comments |
---|---|---|
force boolean |
| Force volume group creation. |
pp_size integer | The size of the physical partition in megabytes. | |
pvs list / elements=string | List of comma-separated devices to use as physical devices in this volume group. Required when creating or extending ( present state) the volume group.If not informed reducing ( absent state) the volume group will be removed. | |
state string |
| Control if the volume group exists and volume group AIX state varyonvg varyon or varyoffvg varyoff . |
vg string / required | The name of the volume group. | |
vg_type string |
| The type of the volume group. |
Note
- name: Create a volume group datavg community.general.aix_lvg: vg: datavg pp_size: 128 vg_type: scalable state: present - name: Removing a volume group datavg community.general.aix_lvg: vg: datavg state: absent - name: Extending rootvg community.general.aix_lvg: vg: rootvg pvs: hdisk1 state: present - name: Reducing rootvg community.general.aix_lvg: vg: rootvg pvs: hdisk1 state: absent
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/community/general/aix_lvg_module.html