W3cubDocs

/Qt 5.11

Installing clang for QDoc

As of this writing, the decision of whether to use static or dynamic linking of libclang has not been made. The most likely outcome will be to include libclang in the binary packages with QDoc and have the installer put libclang in the same directory used for Creator's libclang. It is hoped that both Creator and QDoc will eventually use the same version of libclang, but as of this writing, QDoc might require a later version of libclang than is required for Creator.

As of this writing, users wishing to build and/or run QDoc must install LLVM 3.9 or greater and set the variable LLVM_INSTALL_DIR accordingly. The pre-built binaries needed can be found here.

© The Qt Company Ltd
Licensed under the GNU Free Documentation License, Version 1.3.
https://doc.qt.io/qt-5/qdoc-guide-clang.html