W3cubDocs

/WordPress

wp_update_plugin( $plugin, $feedback = '' )

This function has been deprecated. Use Plugin_Upgrader() instead.

This was once used to kick-off the Plugin Updater.

Description

Deprecated in favor of instantating a Plugin_Upgrader instance directly, and calling the ‘upgrade’ method. Unused since 2.8.0.

See also

Source

File: wp-admin/includes/deprecated.php

function wp_update_plugin($plugin, $feedback = '') {
	_deprecated_function( __FUNCTION__, '3.7.0', 'new Plugin_Upgrader();' );

	if ( !empty($feedback) )
		add_filter('update_feedback', $feedback);

	include( ABSPATH . 'wp-admin/includes/class-wp-upgrader.php' );
	$upgrader = new Plugin_Upgrader();
	return $upgrader->upgrade($plugin);
}

Changelog

Version Description
3.7.0 Use Plugin_Upgrader
2.5.0 Introduced.

© 2003–2019 WordPress Foundation
Licensed under the GNU GPLv2+ License.
https://developer.wordpress.org/reference/functions/wp_update_plugin